Platform-wide performance degradation
Incident Report for Grow.com
Resolved
This incident has been resolved.
Posted Feb 25, 2022 - 08:53 MST
Investigating
Grow is experiencing minor performance issues with intermittent but rare spikes that significantly decrease performance and may result in 504 responses.

We've identified the problem and will be working on a resolution as soon as possible.
Posted Feb 23, 2022 - 09:55 MST
This incident affected: Builder and Dashboards and Metric Utilities.