Facebook and Instagram Down
Incident Report for Grow.com
Resolved
This incident has been resolved.
Posted Mar 05, 2024 - 12:53 MST
Identified
Facebook and Instagram appear to be down. https://downdetector.com/status/facebook/
Posted Mar 05, 2024 - 08:53 MST
This incident affected: Integrations (Facebook, Facebook Ads, Instagram).