Grow Facebook Outage
Incident Report for Grow.com
Resolved
This incident has been resolved.
Posted Feb 05, 2022 - 18:56 MST
Update
We are continuing to work on a fix for this issue.
Posted Feb 04, 2022 - 16:20 MST
Identified
We’ve identified the issue and are taking steps to address this as quickly as possible.
Posted Feb 03, 2022 - 08:29 MST
Investigating
Grow's connection to Facebook has been disrupted. We are currently investigating the issue and will provide updates as soon as we have any.
Posted Feb 03, 2022 - 07:54 MST
This incident affected: Integrations (Facebook).