Twitter Connector: Expected Outage April 29th
Incident Report for Grow.com
Resolved
This incident has been resolved.
Posted Jun 12, 2023 - 15:02 MDT
Update
Our Twitter connector is down. We have been notified that our application has been suspended, most likely due to the new tiers launch. We have submitted a ticket to get more information and appeal the decision.

This has not affected our Twitter Ads connector.

More details to follow.
Posted Apr 11, 2023 - 13:05 MDT
Monitoring
On March 29th, 2023 we were informed by Twitter that new API Access tiers were launched. The plan option the Grow connector utilizes is scheduled to encounter heavy restriction beginning on April 29th, 2023. As of right now, no restrictions have been applied and the Twitter connections within Grow remain operational.

If Twitter does not revert this decision, we anticipate that Twitter connections in Grow will encounter error messages beginning April 29th. In reviewing the new API Access tiers provided by Twitter, the Grow team has determined that we will not be able to continue supporting a native Twitter connector should these changes go into effect April 29th.

Given these updates, our recommendation is to explore alternative ways to get this data into Grow in order to minimize any disruption.

Please note the only communication we have received related to this is specific to the Twitter API and does not make any mention of the Twitter Ads API. At this time the Grow team will do everything possible to maintain the Twitter Ads API as it currently stands.

We will continue to monitor the situation and will post relevant updates here as we have them. While this decision is out of our control, we do apologize for any inconvenience this may cause.

Please reach out to our support team if you have any questions.
Posted Apr 04, 2023 - 07:57 MDT
This incident affected: Integrations (Twitter, Twitter Ads).