Salesforce Connection Issue
Incident Report for Grow.com
Resolved
Salesforce has resolved the issue.
Posted May 04, 2021 - 19:26 MDT
Identified
Customers may have trouble loading or connecting to Salesforce data at this time. This is a Salesforce issue and we're monitoring their status updates. Please see Salesforce's Status Page here: https://status.salesforce.com/incidents/7125
Posted May 04, 2021 - 10:14 MDT
This incident affected: Data Sources (Salesforce, SalesforceIQ, Salesforce Marketing Cloud).