Intermittent Slowness
Incident Report for Grow.com
Resolved
The incident has been resolved.
Posted Jul 16, 2024 - 19:14 MDT
Monitoring
A fix has been implemented and we are monitoring the results.
Posted Jul 16, 2024 - 18:59 MDT
Investigating
Users continue to experience slowness. Additional investigation into the cause of the issue is underway.
Posted Jul 16, 2024 - 18:00 MDT
Monitoring
A fix has been implemented and we are monitoring the results.
Posted Jul 16, 2024 - 17:02 MDT
Update
Users may experience slow load times, blank pages, and errors when using Grow. This issue is intermittent and under investigation.
Posted Jul 16, 2024 - 16:04 MDT
Investigating
Grow is experiencing intermittent slowness. The issue is being investigated.
Posted Jul 16, 2024 - 15:58 MDT
This incident affected: Builder and Dashboards, Metric Utilities, and Whitelabel.