Intermittent Performance Outage

Incident Report for Grow.com

Resolved

This incident has been resolved.
Posted Apr 25, 2025 - 08:28 MDT

Investigating

Grow has been experiencing intermittent performance issues. Performance has improved for some accounts but the situation continues to be monitored and improvements are continuing to be made. Please report any new performance issues to Grow Support.
Posted Apr 23, 2025 - 10:42 MDT
This incident affected: Builder and Dashboards and Metric Utilities.