Grow Partial Outage

Incident Report for Grow.com

Resolved

This incident has been resolved.
Posted Apr 05, 2023 - 13:14 MDT

Monitoring

A fix has been implemented and we are monitoring the results.
Posted Apr 05, 2023 - 08:57 MDT

Investigating

We are currently investigating this issue.
Posted Apr 05, 2023 - 07:29 MDT
This incident affected: Builder and Dashboards, Metric Utilities, and Whitelabel.