Facebook Ads Connector Outage

Incident Report for Grow.com

Resolved

This incident has been resolved.
Posted Apr 27, 2026 - 13:50 MDT

Identified

There is an issue with Facebook Ads connector that we are working to resolve. We are currently waiting for Facebook to restore connectivity.
Posted Apr 27, 2026 - 09:55 MDT
This incident affected: Integrations (Facebook Ads).