Customers may have trouble connecting to or using Grow
Incident Report for Grow.com
Resolved
The Grow Application encountered a connectivity issue resulting in 504 Bad Gateway errors for the majority of customers.

The issue has been resolved. We apologize for any inconvenience this may have caused.

There should be no residual errors occurring from this outage, but if you have any questions, please reach out to support@grow.com
Posted Apr 29, 2021 - 19:43 MDT
Monitoring
A fix has been implemented and we're currently monitoring.
Posted Apr 29, 2021 - 16:46 MDT
Investigating
Customers may have trouble loading or connecting to Grow at this time. Our team is investigating and we'll follow up with more information as soon as we have it. We apologize for any disruption caused.
Posted Apr 29, 2021 - 16:16 MDT
This incident affected: Builder and Dashboards and Metric Utilities.