Xero outage
Incident Report for Grow.com
Resolved
This was limited to one customer's rate limits. We are working on a permanent fix.
Posted Jan 31, 2025 - 09:15 MST
Monitoring
A fix has been implemented and we are monitoring the results.
Posted Jan 28, 2025 - 05:56 MST
Investigating
We are currently investigating this issue.
Posted Jan 24, 2025 - 11:08 MST
This incident affected: Integrations (Xero).