Outage Incident

Incident Report for Grow.com

Resolved

The root cause of the issue has been identified, and steps have been taken to mitigate further impact. Service has been restored.
Posted Jul 21, 2025 - 13:07 MDT

Monitoring

A fix has been implemented and we are monitoring the results.
Posted Jul 21, 2025 - 10:42 MDT

Update

We are continuing to investigate this issue.
Posted Jul 21, 2025 - 10:39 MDT

Investigating

We are currently investigating reports of slowness.
Posted Jul 21, 2025 - 10:25 MDT