LinkedIn Ads Outage
Incident Report for Grow.com
Resolved
This incident has been resolved.
Posted Mar 22, 2023 - 15:12 MDT
Investigating
Grow's connection to LinkedIn Ads has been disrupted and users are unable to reconnect. We are currently investigating the issue and will provide updates as soon as we have any.
Posted Mar 22, 2023 - 14:50 MDT
This incident affected: Integrations (LinkedIn Ads).